# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\s*\b[a-z]+[A-Z][a-zA-Z]+\b//gm;t' <<< "I like strawBerries
I like Strawberries"