$re = '/\s*\b[a-z]+[A-Z][a-zA-Z]+\b/m';
$str = 'I like strawBerries
I like Strawberries';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;