# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"test2(?:\n.*test[234])*?\n.*test4"
test_str = (" 1 test1\n"
" 2 test2\n"
" 5 test5\n"
" 6 test1\n"
" 7 test2\n"
" 8 test3\n"
" 9 test4\n"
" 10 test5\n"
" 11 test1\n"
" 12 test2\n"
" 13 test3\n"
" 14 test4\n"
" 15 test5\n\n"
" 1 test1\n"
" 2 test2\n"
" 5 test5\n"
" 6 test1\n"
" 7 test2\n"
" 8 test3\n"
" 9 test4\n"
" 10 test5\n"
" 11 test1\n"
" 12 test2\n"
" 13 test3\n"
" 14 test4\n"
" 14 test4\n"
" 14 test4\n"
" 15 test5")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.