# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^from\s+
(?P<package_name>[.\w]+)\s+
import\s+
(\()?
(?(2)
(?P<object>[^()]+)\)
|
(?P<object2>(?:.+[\n\r]?)+)
)
"""
test_str = ("from .sql.base import (\n"
" SchemaVisitor\n"
" )\n"
"import os # ignore this import\n"
"from _pytest.config import (\n"
" main, UsageError, cmdline,\n"
" hookspec, hookimpl\n"
")\n\n"
"I can capture this with:\n\n"
"syntax1 = re.compile(r'^ *from (?P<package>[.\\w]+) +import +\\(?(?P<objects>[*, \\n\\w]+)\\)? *$',\n"
" flags=re.MULTILINE)\n\n"
"Syntax #2 uses line continutation (if needed), and technically has no newlines within the import statement:\n\n"
"from pandas import Series\n\n"
"from .solvers import solve, solve_linear_system, solve_linear_system_LU, \\\n"
" solve_undetermined_coeffs, nsolve, solve_linear, checksol, \\\n"
" det_quick, inv_quick, check_assumptions\n\n"
"from .ode import checkodesol, classify_ode, dsolve, \\\n"
" homogeneous_order")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.