#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{8,16}"
Local $sString = "1aAbcdef" & @CRLF & _
"1aAAAAAA" & @CRLF & _
"a123AAAA" & @CRLF & _
"f345bC#4" & @CRLF & _
"f345bCdf"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")