$re = '/(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).{8,16}/';
$str = '1aAbcdef
1aAAAAAA
a123AAAA
f345bC#4
f345bCdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);