use strict;
my $str = 'a 123 234 b
- Has to match 123 and 234
a 123_234 b
- Has to match 123 and 234
aa123 234 b
- Has to match 123 and 234
a0123 234 b
- Has to match only 234
123a234 b
- Has to match 123 and 234
a 123 234
- Has to match 123 and 234';
my $regex = qr/(?<!\d)\d{3}(?!\d)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}