// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^\s\d]+\s+[^\s\d]+) (\d+)").unwrap();
let string = " 2012-15-08 07:05 *** Error importing row no. 5: The import of 785 line failed because of 345 item";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}