$re = '/(?<=Match)\n(\s+)\w+(?:\n\1\w+)+/m';
$str = ' Connection
Match
Fridolin
Marten
Connection
Inventory
Fill Up
Fill Up
Match
Peter
Marcus
Storage
Room 1
Room 2
Room 3
Match
Albert
Jona
Hans
List
Match
Peter
Marcus
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);