import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Candidate name:\\s*(Dr.|Mr.|Mrs.|Ms.)?\\K.*";
final String string = "Candidate name:No Space\n"
+ "Candidate name: Madonna\n"
+ "Candidate name: John Smith\n"
+ "Candidate name: John Jacob Jingelheimer Schmidt\n"
+ "Candidate name: Dr. Viktor Frankenstein\n"
+ "Candidate name: Mr. Magoo\n"
+ "Candidate name: Mrs. Doubtfire\n"
+ "Candidate name: Dashy Hasa-Dasherson\n"
+ "Candidate name: Anne-Marie Hasadasher\n"
+ "Candidate name: Apostrophe O'Donnell\n"
+ "Candidate name: 尹希\n"
+ "Candidate name: 益川 敏英\n"
+ "Candidate name: Erwin Schrödinger";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}