# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b([^\s*][a-zA-Z_\.\s]+)\b//gmi;t' <<< "Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook"