// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b([^\s*][a-zA-Z_\.\s]+)\b").unwrap();
let string = "Elon R. Musk (245)436-7956 Jeff Bezos (235)231-3432 Tim Cook";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}