const regex = /<{\s*_N\s*\(\s*'([^\\']*(?:\\.[^\\']*)*)'\s*,\s*'([^\\']*(?:\\.[^\\']*)*)'\s*(.*?)}>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<{\\s*_N\\s*\\(\\s*\'([^\\\\\']*(?:\\\\.[^\\\\\']*)*)\'\\s*,\\s*\'([^\\\\\']*(?:\\\\.[^\\\\\']*)*)\'\\s*(.*?)}>', 'g')
const str = `<{_N( 'some_domain_id' , 'this \\'can\\' be an arbitary string',{'a':'b','c':'d'})}>
<{_N( 'some_domain_id' , 'this can ( be an arbitary ) string',{'a':'b','c':'d'})}>
<{_N( 'some_domain_id' , 'this can be an arbitary string' {'a':'b','c':'d'})|e('modifier')}>
<{_N( 'some_domain_id' , 'this can be an arbitary string')|e('modifier')}>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}