#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(Paul Green|Paul Gree|Paul|paul|pau|Gr|pele|Pel|john|joh)"
Local $sString = "Paul Green" & @CRLF & _
"Paul" & @CRLF & _
"Pelè" & @CRLF & _
"paul" & @CRLF & _
"walker" & @CRLF & _
"johnny" & @CRLF & _
"Green"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")