package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<key>[^=\s]+)\s*="*(?<value>[^"]+)`)
var str = `Include =" reg2reg,in2reg,in2out,reg2out "
Include="reg2reg,in2reg,in2out,reg2out
Include=reg2reg,in2reg,in2out,reg2out"
Include=reg2reg,in2reg,in2out,reg2out
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}