$re = '/(?<=[^AZ-az]_).\S+\d/m';
$str = 'DM1_65_78109” OR SL1_78_72947';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);