import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\*\\d+)+#$";
final String string = "*123#\n"
+ "// Must be true\n"
+ "*1*2*3#\n"
+ "// Must be true\n"
+ "*1#23#\n"
+ "// Must be false\n"
+ "***123###\n"
+ "// Must be false\n"
+ "*12**3#\n"
+ "// Must be false";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}