re = /^poliamb\/(?P<m_path>\w+(?:-\w+)*)\/?$/m
str = 'poliamb/test1
poliamb/test1-other
poliamb/test1/
poliamb/test1-other/
poliamb/test1---other
poliamb/test1---other/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end