using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\w+([-+.']\w+)*@\w+([-.]\w+)*\.\w+([.]\w+)*$";
string input = @"barney@example.de
barney.rubble@example.com
barney-rubble@example.coop
barney+rubble@example.com
barney'rubble@example.com
b.arne.y_r.ubbl.e@example.com
barney4rubble@example.com
barney4rubble!@example.com
_barney+rubble@example.com
""barney+rubble""@example.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}