#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?<title>(?:[^\s\.]+\.){1}) +)*(?<first>\S+)(?: *(?<middle>[^,\n\r]+)*? +(?<last>[^,\s]+)*)*(?:, *(?<suffix>[^\n]+))*$"
Local $sString = "Ryan" & @CRLF & _
"Ryan William" & @CRLF & _
"Ryan William Toner" & @CRLF & _
"Mr. Ryan William Toner" & @CRLF & _
"Ryan William Corey Toner" & @CRLF & _
"Ryan William Corey Toner, Jr" & @CRLF & _
"Mr. Ryan William Corey Toner, Jr." & @CRLF & _
"Dr. Ryan William Corey Toner, III" & @CRLF & _
"AJ" & @CRLF & _
"A.J." & @CRLF & _
"A.J. Toner" & @CRLF & _
"Mr. AJ Toner" & @CRLF & _
"Mr. A.J. Christian Toner, Sr." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")