const regex = /^(?:(?<title>(?:[^\s\.]+\.){1}) +)*(?<first>\S+)(?: *(?<middle>[^,\n\r]+)*? +(?<last>[^,\s]+)*)*(?:, *(?<suffix>[^\n]+))*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?<title>(?:[^\\s\\.]+\\.){1}) +)*(?<first>\\S+)(?: *(?<middle>[^,\\n\\r]+)*? +(?<last>[^,\\s]+)*)*(?:, *(?<suffix>[^\\n]+))*$', 'gm')
const str = `Ryan
Ryan William
Ryan William Toner
Mr. Ryan William Toner
Ryan William Corey Toner
Ryan William Corey Toner, Jr
Mr. Ryan William Corey Toner, Jr.
Dr. Ryan William Corey Toner, III
AJ
A.J.
A.J. Toner
Mr. AJ Toner
Mr. A.J. Christian Toner, Sr.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}