#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)((?<=\/23836\*).+?(?=\*23836\/))|((?<=\/23836\/)[^*].+?[\n])"
Local $sString = "#include <iostream>" & @CRLF & _
"#include <stdlib.h>" & @CRLF & _
"" & @CRLF & _
"#define MAX 256" & @CRLF & _
"/23836//23836/Definiramo konstanto MAX" & @CRLF & _
"" & @CRLF & _
"int main() {" & @CRLF & _
" /23836*Vstopna točka programa" & @CRLF & _
" Ne uporabljamo parametrov pri main, kjer jih ne potrebujemo" & @CRLF & _
"" & @CRLF & _
" *23836/" & @CRLF & _
" printf("");/23836/izpis vrednosti konstante MAX" & @CRLF & _
"" & @CRLF & _
" return 0;" & @CRLF & _
"}" & @CRLF & _
"/23836/Končamo z izvajanjem programa" & @CRLF & _
"" & @CRLF & _
"/23836//23836/komentar/23836/" & @CRLF & _
"" & @CRLF & _
"/23836//23836*Testni komentar/23836/ /23836* /23836/" & @CRLF & _
"" & @CRLF & _
"/23836*komentar/23836/nov komentar/test/23836/*23836/" & @CRLF & _
"" & @CRLF & _
"/23836*/**Kaj pa ta vzorec?*/23836* /23836**23836/" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"(?<=\/23836\/).*?|(?<=\/23836\*)[\S\s]*(?=\*23836\/)/gmU" & @CRLF & _
"((?<=\/23795\*).+?(?=\*23795\/))|((?<=\/23795\/)[^*].+?[\n])" & @CRLF & _
"" & @CRLF & _
"(?<=\/23836\/).*$|(?<=\/23836\*)(.*$\n.*\n.*\n.*)(?=\*23836\/)|(?<=\/23836\*)(.|\n)*(?=\*23836\/)|(?<=\/23836\*).*(?=\*23836\/)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")