using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<=\/23836\*).+?(?=\*23836\/))|((?<=\/23836\/)[^*].+?[\n])";
string input = @"#include <iostream>
#include <stdlib.h>
#define MAX 256
/23836//23836/Definiramo konstanto MAX
int main() {
/23836*Vstopna točka programa
Ne uporabljamo parametrov pri main, kjer jih ne potrebujemo
*23836/
printf("");/23836/izpis vrednosti konstante MAX
return 0;
}
/23836/Končamo z izvajanjem programa
/23836//23836/komentar/23836/
/23836//23836*Testni komentar/23836/ /23836* /23836/
/23836*komentar/23836/nov komentar/test/23836/*23836/
/23836*/**Kaj pa ta vzorec?*/23836* /23836**23836/
(?<=\/23836\/).*?|(?<=\/23836\*)[\S\s]*(?=\*23836\/)/gmU
((?<=\/23795\*).+?(?=\*23795\/))|((?<=\/23795\/)[^*].+?[\n])
(?<=\/23836\/).*$|(?<=\/23836\*)(.*$\n.*\n.*\n.*)(?=\*23836\/)|(?<=\/23836\*)(.|\n)*(?=\*23836\/)|(?<=\/23836\*).*(?=\*23836\/)";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}