import Foundation
let pattern = #"((?<=\/23836\*).+?(?=\*23836\/))|((?<=\/23836\/)[^*].+?[\n])"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = ##"""
#include <iostream>
#include <stdlib.h>
#define MAX 256
/23836//23836/Definiramo konstanto MAX
int main() {
/23836*Vstopna točka programa
Ne uporabljamo parametrov pri main, kjer jih ne potrebujemo
*23836/
printf("");/23836/izpis vrednosti konstante MAX
return 0;
}
/23836/Končamo z izvajanjem programa
/23836//23836/komentar/23836/
/23836//23836*Testni komentar/23836/ /23836* /23836/
/23836*komentar/23836/nov komentar/test/23836/*23836/
/23836*/**Kaj pa ta vzorec?*/23836* /23836**23836/
(?<=\/23836\/).*?|(?<=\/23836\*)[\S\s]*(?=\*23836\/)/gmU
((?<=\/23795\*).+?(?=\*23795\/))|((?<=\/23795\/)[^*].+?[\n])
(?<=\/23836\/).*$|(?<=\/23836\*)(.*$\n.*\n.*\n.*)(?=\*23836\/)|(?<=\/23836\*)(.|\n)*(?=\*23836\/)|(?<=\/23836\*).*(?=\*23836\/)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)