#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=pow\().*?(?=,2\))"
Local $sString = "pow(alpha,2) + pow(beta,2)" & @CRLF & _
"3*pow(betaR_Full,2))" & @CRLF & _
"2/pow(betaDFull,3))" & @CRLF & _
"-pow(epsilon_gamma,2)+5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")