import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=pow\\().*?(?=,2\\))";
final String string = "pow(alpha,2) + pow(beta,2)\n"
+ "3*pow(betaR_Full,2))\n"
+ "2/pow(betaDFull,3))\n"
+ "-pow(epsilon_gamma,2)+5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}