use strict;
my $str = 'pow(alpha,2) + pow(beta,2)
3*pow(betaR_Full,2))
2/pow(betaDFull,3))
-pow(epsilon_gamma,2)+5';
my $regex = qr/(?<=pow\().*?(?=,2\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}