re = /^application\/(.+\+)?json$/m
str = 'application/json
application/vnd.schemaregistry.v1+json'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end