const regex = new RegExp('^[^\\s/\\#6]{221}$', 'g')
const str = `<?=(function(\$n,\$snake){foreach(array_chunk(range(1,\$n*\$n),\$n)as\$i=>\$a){if(\$i%2)\$a=array_reverse(\$a);echo"\\n",join('',array_map(function(\$e){return(sprintf("%3d",\$e));},\$a));}})(\$argv[1],'-=-=-=-=-=-=-=-=-=-=-=-=-=-o~')?>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}