use strict;
my $str = 'node
1077_shift_factor_avg
1694_shift_factor_avg
1922_shift_factor_avg
';
my $regex = qr/(\d+).+/mp;
my $subst = 'cnstrnt_\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";