# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<?=>)|[^[:upper:]+|^ ]/\1/g;t' <<< "aA azee + B => C="