$re = '/(<?=>)|[^[:upper:]+|^ ]/';
$str = 'aA azee + B => C=';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;