using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(vista)";
string input = @"Hermoso departamento 3 ambientes al frente , muy luminoso con vista panoramica . Cocina integrada , baño completo , balcon aterrazado vidriado con cerramientos . Agua caliente central , Abl: $ 276.-A 1 cuadra de Av. Rivadavia al 2600 y a 2 de Av. Pueyrredon , Subte A , Trenes , Ramales de Colectivos. A 2 cuadras del Shopping Spinetto. A pocas cuadras del Congreso de la Nación. .Información Adicional: Monto de las expensas: 1900Gas naturalGas naturalCaracterísticas y servicios del edificio: Agua corrienteElectricidadGas natural
ID: 221464";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}