$re = '/([^.]+)\.\s+(\D+)\s+(\d\.\d{2})/m';
$str = '612. Grt. Am. Mgt. & Inv. 7.33
77. Wickes 4.61
265. Wang Labs 8.75
9. CrossLand Savings 6.32
228. JPS Textile Group 2.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);