// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)WebAPI login failure\. Reason: invalid credentials.*?((?:[0-9]{0,3}\.){3}[0-9]{0,3})").unwrap();
let string = "(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: invalid credentials, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf
(W) 2024-04-28T17:30:57 - WebAPI login failure. Reason: other reason, attempt count: 3, IP: ::ffff:192.168.2.167, username: fdasdf";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}