#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(\s*)hosts:.*"
Local $sString = "# Configure what output to use when sending the data collected by the beat." & @CRLF & _
" " & @CRLF & _
" #-------------------------- Elasticsearch output ------------------------------" & @CRLF & _
" output.elasticsearch:" & @CRLF & _
" # Array of hosts to connect to." & @CRLF & _
" " & @CRLF & _
" hosts: ["**ELASTICHOSTS**"]"
Local $sSubst = "\1hosts: Db.es-dev.com:9200"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)