# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*)hosts:.*"
test_str = ("# Configure what output to use when sending the data collected by the beat.\n"
	" \n"
	" #-------------------------- Elasticsearch output ------------------------------\n"
	" output.elasticsearch:\n"
	"   # Array of hosts to connect to.\n"
	" \n"
	"   hosts: [\"**ELASTICHOSTS**\"]")
subst = "\\1hosts: Db.es-dev.com:9200"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
    print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.