#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/www\.example\.com(?:\/[a-zA-Z]+)*(?:\/\d+\.html)?$"
Local $sString = "https://www.example.com" & @CRLF & _
"https://www.example.com/demo" & @CRLF & _
"https://www.example.com/demo/abc" & @CRLF & _
"https://www.example.com/demo/abc/123.html" & @CRLF & _
"" & @CRLF & _
"不匹配:" & @CRLF & _
"" & @CRLF & _
"https://www.example.com/demo/abc/efg123.html" & @CRLF & _
" (可能含有数字)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")