$re = '/^(?!.*(?:\d+[a-zA-Z]+|[a-zA-Z]+\d+)\.html$)https?:\/\/.+$/m';
$str = 'https://www.example.com
https://www.example.com/demo
https://www.example.com/demo/abc
https://www.example.com/demo/abc/123.html
不匹配:
https://www.example.com/demo/abc/efg123.html
(可能含有数字)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);