const regex = /(?:\d{4}-\d{2}-\d{2})(.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\d{4}-\\d{2}-\\d{2})(.*)', 'gm')
const str = `2020-04-14 17:00:00
2012-01-01T17:52:27.8116975-12:00
2012-02-01T18:21:06
2012-03-01T00:00:00Z`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}