use strict;
my $str = '2020-04-14 17:00:00
2012-01-01T17:52:27.8116975-12:00
2012-02-01T18:21:06
2012-03-01T00:00:00Z';
my $regex = qr/(?:\d{4}-\d{2}-\d{2})(.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}