use strict;
my $str = '< 2 Mbps
> 2 Mbps
! 2 Mbps
<2 Mbps
>2 Mbps
!2 Mbps
<2Mbps
>2Mbps
!2Mbps
< 1.5 Mbps
> 1.5 Mbps
! 1.5 Mbps
<1.5 Mbps
>1.5 Mbps
!1.5 Mbps
<1.5Mbps
>1.5Mbps
!1.5Mbps
< 1.5 Mbps
< 1.5 M
< 1.5 Kbps
< 1.5 K
2 Mbps
2Mbps
';
my $regex = qr/^([<>=!]?)\s?((?:\d*\.)?\d+)\s?(.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}