import Foundation
let pattern = #"^[\-]?(?:\d{0,2})[\.]?(?:[\d]{1})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
0.23455465
4.54656
-334343
-.34234234
234234.4234234
23123
323-312312
-12121.34344
asdasd
2312
213.3213.3213
1.4
221.4
-22.4
22
.4
1.0
99.0
-999
f.3
100.2
100
234.3
2
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)