using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b((?:id)*)(?=\S)|((?:id)+\b|\b(?<!id))|((?:id)+)";
string substitution = @"${1:+[}${2:+]}${3:+, }";
string input = @"longstringwithid1234andid4321init
id1id2id3
id213123213id12321321id
id123421321id12312321id65464
thereisandidanditsnameisbingoidbingoidbingoid2312321
ghjjhghjgd
dsadsadasdsaididididididdsadsadsa
dsa
das id dsadassa id sdadasdsa
idsa2311321id2312312id21321312
ididid1idid2idid3ididid";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}