const regex = /\b((?:id)*)(?=\S)|((?:id)+\b|\b(?<!id))|((?:id)+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b((?:id)*)(?=\\S)|((?:id)+\\b|\\b(?<!id))|((?:id)+)', 'g')
const str = `longstringwithid1234andid4321init
id1id2id3
id213123213id12321321id
id123421321id12312321id65464
thereisandidanditsnameisbingoidbingoidbingoid2312321
ghjjhghjgd
dsadsadasdsaididididididdsadsadsa
dsa
das id dsadassa id sdadasdsa
idsa2311321id2312312id21321312
ididid1idid2idid3ididid`;
const subst = `${1:+[}${2:+]}${3:+, }`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);