# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b((?:id)*)(?=\S)|((?:id)+\b|\b(?<!id))|((?:id)+)"
test_str = ("longstringwithid1234andid4321init\n\n"
"id1id2id3\n\n"
"id213123213id12321321id\n"
"id123421321id12312321id65464\n"
"thereisandidanditsnameisbingoidbingoidbingoid2312321\n"
"ghjjhghjgd\n"
"dsadsadasdsaididididididdsadsadsa\n"
"dsa\n"
"das id dsadassa id sdadasdsa \n"
"idsa2311321id2312312id21321312\n\n"
"ididid1idid2idid3ididid")
subst = "${1:+[}${2:+]}${3:+, }"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.