import Foundation
let pattern = #"\b((?:id)*)(?=\S)|((?:id)+\b|\b(?<!id))|((?:id)+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
longstringwithid1234andid4321init
id1id2id3
id213123213id12321321id
id123421321id12312321id65464
thereisandidanditsnameisbingoidbingoidbingoid2312321
ghjjhghjgd
dsadsadasdsaididididididdsadsadsa
dsa
das id dsadassa id sdadasdsa
idsa2311321id2312312id21321312
ididid1idid2idid3ididid
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1:+[}${2:+]}${3:+, }"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)