#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(PJSIP|SIP)\/(\d{3,5})-(AA[0-9]{5})"
Local $sString = "PJSIP/117-AA01002-00000039" & @CRLF & _
"SIP/117-AA01002-00000039" & @CRLF & _
"SIP/1030-AA01002-00000039" & @CRLF & _
"PJSIP/10301-AA01002-00000039" & @CRLF & _
"Local/DIAL-8297225031@fromotherpbx-0000004e;2" & @CRLF & _
"Local/132-54-0@dialfromfollowme-00000022;2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")