const regex = /(PJSIP|SIP)\/(\d{3,5})-(AA[0-9]{5})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(PJSIP|SIP)\\\/(\\d{3,5})-(AA[0-9]{5})', 'gm')
const str = `PJSIP/117-AA01002-00000039
SIP/117-AA01002-00000039
SIP/1030-AA01002-00000039
PJSIP/10301-AA01002-00000039
Local/DIAL-8297225031@fromotherpbx-0000004e;2
Local/132-54-0@dialfromfollowme-00000022;2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}