# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(PJSIP|SIP)\/(\d{3,5})-(AA[0-9]{5})"
test_str = ("PJSIP/117-AA01002-00000039\n"
"SIP/117-AA01002-00000039\n"
"SIP/1030-AA01002-00000039\n"
"PJSIP/10301-AA01002-00000039\n"
"Local/DIAL-8297225031@fromotherpbx-0000004e;2\n"
"Local/132-54-0@dialfromfollowme-00000022;2")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.